Configuration Issues (構成問題) HAエージェントエラー

 

HA agent on vmware-esx35-01.domain.local in cluster vmware-esx35-01.domain.local in datacenter01 has an error 


■ 現象

VIClientでVirtualCenterに接続し、ホスト(VMware ESX)vmware-esx35-01のサマリを表示すると、トップに以下のメッセージが表示される
Configuration Issues
HA agent on vmware-esx35-01.domain.local in cluster vmware-esx35-01.domain.local in datacenter01 has an error 

VI3.5 の仮想化環境状態的には、HA構成に問題がある状態にる。

しかし今回の問題対象、VMware ESXホスト(vmware-esx35-01.domain.local)は、HA構成を組んでいないので本来HAエージェントは存在しない。

■ 対応方法

[root@vmware-esx35-01 root]# rpm -qa | grep -i vmware
vmware-hwdata-1.00-13vmw
vmware-keying-data-1-20070727
vmware-release-3-4vmw
VMware-webCenter-esx-2.5.0-147626
VMware-esx-drivers-block-DAC960-350.2.4.11.1vmw-82663
VMware-esx-drivers-net-3c90x-350.1.0.2-82663
VMware-esx-drivers-net-e1000-350.7.6.15.5vmw-153875
VMware-esx-drivers-net-forcedeth-350.1.25-153875
VMware-esx-drivers-net-ixgbe-350.1.3.31.6-153875
VMware-esx-drivers-net-tg3-350.3.81c.1vmw-153875
VMware-esx-drivers-scsi-ahci-350.1.2-153875
VMware-esx-drivers-scsi-aic7xxx-350.6.3.9-82663
VMware-esx-drivers-scsi-hpsa-350.2.4.66.95vmw-153875
VMware-esx-drivers-scsi-lpfc_elx_v740-350.7.4.0.40-153875
VMware-esx-drivers-scsi-megaraid_sas-350.3.0.19.1vmw-153875
VMware-esx-drivers-scsi-qla2300-v707_vmw-350.7.8.65-153875
VMware-esx-drivers-scsi-qla4022-350.3.30-113339
VMware-esx-drivers-scsi-sata_promise-350.1.03-153875
VMware-esx-drivers-scsi-sata_svw-350.1.07-153875
VMware-esx-drivers-scsi-vmkiscsi-350.3.6.3-153875
VMware-esx-ima-qla4xxx-3.5.0-123630
VMware-esx-uwlibs-3.5.0-64607
VMware-esx-3.5.0-153875
VMware-esx-perftools-3.5.0-153875
VMware-esx-vmkctl-3.5.0-169697
VMware-esx-srvrmgmt-3.5.0-158874
VMware-esx-tools-3.5.0-169697
VMware-esx-drivers-net-bnx2-350.1.5.10b.1.1-158874
VMware-esx-drivers-scsi-aacraid_esx30-350.1.1.5.3vmw-163429
VMware-aam-haa-2.2.0-1
VMware-esx-drivers-net-pcnet32-1.30c-52542
vmware-python-libs-0.99-8vmw
VMware-esx-docs-3.5.0-153875
VMware-esx-apps-3.5.0-153875
VMware-esx-lnxcfg-3.5.0-153875
VMware-esx-drivers-block-cciss-350.2.4.66.6vmw-153875
VMware-esx-drivers-ioat-350.7.0.33-82663
VMware-esx-drivers-net-e100-350.2.3.40-82663
VMware-esx-drivers-net-e1000e-350.0.4.1.7-153875
VMware-esx-drivers-net-igb-350.1.0.0-82663
VMware-esx-drivers-net-s2io-350.2.1.0.10458-82663
VMware-esx-drivers-scsi-adp94xx-350.0.0.6-82663
VMware-esx-drivers-scsi-aic79xx-350.6.3.9-82663
VMware-esx-drivers-scsi-ata_piix-350.1.05-153875
VMware-esx-drivers-scsi-ips-350.7.10.17.1vmw-82663
VMware-esx-drivers-scsi-megaraid2-350.2.10.7.vm1-84374
VMware-esx-drivers-scsi-mptscsi_2xx-350.2.6.48.18vmw-153875
VMware-esx-drivers-scsi-qla4010-350.3.30-82663
VMware-esx-drivers-scsi-sata_nv-350.0.8-153875
VMware-esx-drivers-scsi-sata_sil-350.0.9-153875
VMware-esx-drivers-scsi-sata_vsc-350.1.1-153875
VMware-esx-backuptools-3.5.0-153875
VMware-cim-esx-3.5.0-153875
VMware-esx-scripts-3.5.0-158874
VMware-esx-vmkernel-3.5.0-169697
VMware-esx-iscsi-3.5.0-158874
VMware-esx-vmx-3.5.0-169697
VMware-esx-drivers-net-bnx2x-350.1.45.20-169697
VMware-esx-drivers-net-unm_nic-350.4.0.275-169697
VMware-hostd-esx-3.5.0-163429
VMware-vpxa-2.5.0-119598
VMware-aam-vcint-2.2.0-1


[root@vmware-esx35-01 root]# rpm -qa | grep -i aam
VMware-aam-haa-2.2.0-1
VMware-aam-vcint-2.2.0-1

[root@vmware-esx35-01 root]# rpm -e VMware-aam-haa-2.2.0-1
error: Failed dependencies:
        VMware-aam-haa is needed by (installed) VMware-aam-vcint-2.2.0-1
[root@vmware-esx35-01 root]# rpm -e VMware-aam-haa-2.2.0-1 VMware-aam-vcint-2.2.0-1
File not found.
[2010-01-15 11:24:37.849 'App' 3076456576 info] Current working directory: /usr/lib/vmware/hostd
[2010-01-15 11:24:37.852 'BaseLibs' 3076456576 info] HOSTINFO: Seeing Intel CPU, numCoresPerCPU 4 numThreadsPerCore 1.
[2010-01-15 11:24:37.853 'BaseLibs' 3076456576 info] HOSTINFO: hyperthreading disabled, setting number of threads per core to 1.
[2010-01-15 11:24:37.853 'BaseLibs' 3076456576 info] HOSTINFO: This machine has 2 physical CPUS, 8 total cores, and 8 logical CPUs.
[2010-01-15 11:24:37.854 'BaseLibs' 3076456576 info] System libcrypto.so.0.9.7 library is older than our library (90701F < 90709F)
[2010-01-15 11:24:37.854 'App' 3076456576 info] Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000
[2010-01-15 11:24:37.869 'BaseLibs' 12053424 warning] [Vmdb_Unset] Unsetting unknown path: /vmomi/
Command not found.
/opt/vmware/aam/lib

[root@vmware-esx35-01 root]# rpm -qa | grep -i aam
[root@vmware-esx35-01 root]#

VIClient上にConfiguration Issuesエラーメッセージ変わらず・・・。

[root@vmware-esx35-01 root]# rpm -qa | grep -i vpxa
VMware-vpxa-2.5.0-119598

[root@vmware-esx35-01 root]# rpm -e VMware-vpxa-2.5.0-119598
Stopping vmware-vpxa:[  OK  ]
warning: /etc/opt/vmware/vpxa/vpxa.cfg saved as /etc/opt/vmware/vpxa/vpxa.cfg.rpmsave

VirtualCenter からhost(vmware-esx35-01)を[Remove]
Removing this host will also remove all of its virtual machines and resource pools. Are you sure you want to do this?
OK

VirtualCenter からdatacenterを選択し、[Add Host]

[root@vmware-esx35-01 root]# rpm -qa | grep -i vpxa
VMware-vpxa-2.5.0-119598
[root@vmware-esx35-01 root]# rpm -qa | grep -i aam
[root@vmware-esx35-01 root]#

VIClient上にConfiguration Issuesエラーメッセージがなくなる。
 

サブページ リスト

Comments